Bienvenido a la web de la Oficina del Software Libre y Conocimiento Abierto de la Universidad de Cádiz

Requisitos para el taller de programación en BlackBerry

Para los asistentes al taller de Desarrollo de Aplicaciones Móviles Blackberry se recomienda sigan las siguientes instrucciones preparatorias antes de acudir al taller:

En la página de desarrolladores BlackBerry podrás encontrar toda la información. A continuación se detalla lo necesario según el SDK elegido, aunque es recomendable instalar los dos entornos, que no son excluyentes.

En ambos casos (C/C++/Cascades y HTML5):

BlackBerry Link: Podrás acceder a su contenido (música, fotos, etc.), sincronizarlo y organizarlo tanto en el dispositivo BlackBerry® 10 como en el ordenador.
[Recomendable] BlackBerry 10 Dev Alpha Simulator: Es una máquina virtual de Vmware y por tanto se necesitará:

Para desarrollar en Cascades/C++ en la página de descargas encontrarás lo siguiente:

[Obligatorio] BlackBerry 10 Native SDK: Tanto para Nativo puro en C/C++ como para usar Cascades Framework, es el mismo SDK, que además incluye el IDE Momentics (basado en Eclipse). Disponible para Windows, Mac y Linux.
[Opcional] Adobe® Photoshop® Plug-in: Es un plugin para Photoshop que te permite exportar los diseños a QML automáticamente.

Para desarrollar en HTML5 en la página de herramientas encontrarás lo siguiente:

Ripple emulator: También podrás encontrar Ripple en la Chrome Web Store.
WebWorks SDK: Disponible para Windows y Mac

Por último si has desarrollado en Android y tienes curiosidad por ver cómo reempaquetar tu aplicación para BlackBerry 10, échale un vistazo a la Runtime para aplicaciones Android

Distribuir contenido